secure.credsimple.com is experiencing slow load speeds
Incident Report for CredSimple
Resolved
We have resolved the issue. Site speeds should be back to normal.
Posted Apr 16, 2018 - 13:33 EDT
Investigating
Our site is experiencing slow load speeds and intermittent outages. We are currently investigating the issue.
Posted Apr 16, 2018 - 12:24 EDT