Partial Outage on Provider Application
Incident Report for CredSimple
Resolved
The issue with the provider application has resolved. It should be usable again.
Posted Apr 25, 2018 - 16:26 EDT
Investigating
We are investigating an issue with our provider application that is affecting some users.
Posted Apr 25, 2018 - 14:53 EDT