Provider Import Page Unavailable
Incident Report for CredSimple
Resolved
This incident has been resolved.
Posted Mar 10, 2020 - 17:07 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 10, 2020 - 16:56 EDT
Investigating
There is an issue with the provider import (add providers) page. We are investigating the issue.
Posted Mar 10, 2020 - 16:49 EDT
This incident affected: Web Portal.