Provider applications are not rendering correctly.
Incident Report for CredSimple
Resolved
This incident has been resolved.
Posted Jan 08, 2018 - 15:17 EST
Monitoring
We are monitoring the situation as we work towards possible resolution.
Posted Jan 08, 2018 - 15:13 EST
Investigating
We are investigating an issue where provider applications are not rendering correctly.
Posted Jan 08, 2018 - 14:06 EST