secure.credsimple.com is down
Incident Report for andros
Resolved
This incident has been resolved.
Posted Mar 10, 2020 - 16:27 EDT
Investigating
We are currently investigating this issue.
Posted Mar 10, 2020 - 16:11 EDT
This incident affected: androsCredentialing (Web Portal, Business Intelligence - Files page, Business Intelligence - Reports (Monitors, Expirations, Turnaround Time), Provider Application).