Under Maintenance
Incident Report for CredSimple
Resolved
Maintenance has been completed. Thank you for your patience.
Posted Dec 20, 2017 - 22:09 EST
Identified
The CredSimple web portal and provider application are under maintenance. A short period of downtime is expected.
Posted Dec 20, 2017 - 21:38 EST