Credential Reports, Applications, and other Documents are not viewable on CredSimple
Incident Report for CredSimple
Resolved
This incident has been resolved.
Posted Jan 17, 2018 - 15:45 EST
Update
We have identified the issue.
Posted Dec 27, 2017 - 09:55 EST
Update
Credential Reports, Applications, and other Documents are not viewable on CredSimple and we are investigating the issue"
Posted Dec 27, 2017 - 09:33 EST
Investigating
We are currently investigating this issue.
Posted Dec 27, 2017 - 09:23 EST